Installation

0. Requirements

You need to set up your development environment before you can do anything.

Install Node.js® and npm if they are not already on your machine.

Verify that you are running at least node 8.x.x and npm 5.x.x by running node -v and npm -v in a terminal/console window. Older versions maybe produce errors, but newer versions are fine.

BalmJS workflow using gulp for the build process, so you need install gulp-cli.

$ npm install --global gulp-cli

# Verify
$ gulp -v
# Output: CLI version 2.0.0

1. Installing balm

Install with npm:

$ npm install --save-dev gulp balm

Install with yarn:

$ yarn add --dev gulp balm

2. Configuration

In your project directory, create a file named gulpfile.js in your project root with these contents:

// 1. Import balm
var balm = require('balm');

// 2. Config balm
balm.config = {
  // Your project config
};

// 3. Run balm
balm.go();

Refer to our configuration docs to learn more about config balm.

3. Usage

Run the gulp command in your project directory:

# For development
$ gulp

# For production
$ gulp --production

results matching ""

    No results matching ""